Проверка орфографии яндекс


В старый яндекс вебмастер был встроен инструмент «Проверка орфографии», который я всегда использовал перед тем, как запустить очередной сайт.

aoesT.jpg

Я очень удивился, что в новой версии вебмастера этот инструмент отсутствует.


1054;н эволюционировал в целую библиотеку для автоматической проверки орфографии на сайте — яндекс спеллер.

Это, конечно, круто, но частенько нужно проверить орфографию один раз на одной страничке, например на лендинге.


1053;ет смысла подключать для этого целую библиотеку.

Яндекс по запросу «проверка орфографии на сайте» выдаёт множество ресурсов для онлайн-проверки текста, но никак не всего сайта.

Но мне удалось найти пару сервисов, которые помогут справится с этой задачей:


1. Офорграф от Тёмы лебедева

Очень простой и удобный инcтрумент, напоминающий таковой, в веб мастере, но с явным недостатком — он проверяет только первую 1000 слов на странице, поэтому годится только для проверки не больших страниц.


aoevY.jpg

2. Spell-checker

Полная противоположность орфографу, обширный функционал, есть даже платный тариф. Бесплатно можно проверить не более 100 страниц, что вполне подходит для 90% задач. Основной минус заключается в юзабилити: визуальl.


01;то один лишний клик + ещё одна вкладка + ожидание на её загрузку.

aoew7.jpg

Сервисы, конечно, не идеальные, но со своей задачей справляются. Если у Вас есть чем дополнить список ресурсов пишите, добавлю в статью.


Больше интересной информации в моём блоге.

Консультирую бизнес, стартапы, фрилансеров и других приятных людей тут.

spark.ru

Проверка орфографии онлайн сервисами

Приветствую вас, уважаемые читатели блога Vorabota.ru! В этом материале речь пойдет о бесплатных онлайн сервисах, на которых можно проверить правописание как отдельно взятого слова, так и объемного текста. На мой взгляд, перечисленные в заголовке онлайн сервисы могут сослужить хорошую службу как простому пользователю интернета, так и начинающему Web мастеру. А если после проверки орфографии делается проверка на плагиат, то можно получить текст очень высокого качества.


Многие из нас, как правило, для написания текста пользуются текстовым редактором Word. И при опечатке или допущенной ошибке этот популярный редактор автоматически делает пометки. Но не все слова этот редактор может определять правильно с точки зрения правописания. Думаю, что лучше всего текст проверить на орфографию онлайн ресурсом Яндекс.

А именно, сервисом Спеллер, который поможет обнаружить и исправить орфографические ошибки. Имея в своей базе большое количество русских и иностранных словарей, онлайн сервис Спеллер проверяет правописание на русском, украинском и английском языках. Одним из достоинств этого сервиса является то, что приложение Web-Спеллер может подключить на страницы своего сайта любой Web мастер. Для того чтобы читатели моего блога могли воспользоваться возможностями этого онлайн сервиса по проверке орфографии, я установил модуль прямо на страницу. Этот сервис очень удобно использовать, к примеру, для редактирования текста после распознавания его с изображений или фотографий.

Для того чтобы проверить орфографию онлайн, впишите или вставьте скопированный текст в форму и нажмите кнопку «Проверить правописание».


Работая с текстами, многие Web мастера, как правило, прогоняют для проверки орфографии свои материалы через несколько онлайн сервисов. Но все прекрасно знают и понимают, что ни она программа или специализированный сервис не заменит человека. К примеру, все статьи на этом блоге, которые написал я, прошли «face control» у моей любимой жены. И в то же время нельзя исключить человеческий фактор. Довольно часто бывает, что «глаз замыливается», и тогда ошибка в слове проскакивает незамеченной. В такой ситуации проверка правописания онлайн ресурсом будет весьма полезна. И когда уже статья опубликована на сайте, проверить орфографию можно сервисом Яндекс Вебмастер . Для проверки орфографии достаточно просто ввести URL (адрес) нужной страницы в специальную форму. Этот ресурс рекомендую обязательно запомнить пользователям, которые задумываются создать свой сайт или блог самостоятельно. В дальнейшем этот сервис станет для вас просто отличным помощником.

Также, орфография онлайн хорошо проверяется онлайн сервисом уникального контента Адвего. В результатах проверки орфографии текста этот ресурс выдает статистику по количеству символов и слов, уникальность, водность, тошноту документа и т.д. Просто отличный сервис для работы с текстами, для дальнейшей его оптимизации под поисковые системы.

А вот информационный ресурс Грамота.ру хотелось бы выделить за его замечательную справочную службу. В архиве справочного бюро этого онлайн сервиса можно найти практически любой ответ, связанный с правописанием. А если ответ не будет найден, его можно задать специалистам.


Конечно, онлан сервисов, на которых можно сделать проверку орфографии, в сети очень много. И каждый пользователь использует те сервисы, которые ему больше всего подходят для его задач. Некоторые Web мастера устанавливают на страницы своих сайтов вот такую кнопку Кнопка системы Orphusонлайн системы Orphus . Вполне неплохой способ для читателей, которые обнаружили ошибку и захотели сообщить о ней владельцу сайта. Хотя, на мой взгляд, проверка орфографии текста таким способом больше всего подходит для нединамичных сайтов, где отсутствует обратная связь или возможность оставить комментарии к статьям. Но в большинстве случаев многие Web мастера устанавливают на свои сайты модули для комментариев, через которые можно отправить сообщение для владельца ресурса. И установка такой кнопки на сайт, думаю, теряет смысл (но это мое мнение).

Надеюсь, что онлайн сервисы, которые я кратко описал в этой статье, будут полезны моим читателям. Хочу пожелать всем успехов и удачи. До новых встреч на страницах блога Vorabota.ru

Вас это может заинтересовать:

vorabota.ru

Зачем нужен Спеллер на сайте


Яндекс Спеллер показывает орфографические ошибки в формах сайта, которые заполняются посетителями – обратная связь, оформление заказа и другие. И функции этого сервиса на сайте важны.

Допустим, если у вас интернет-магазин, и посетителям приходится писать свой адрес и контакты в формах, то если они допустят ошибку, купленный товар может уйти совсем не на тот адрес. А это не в ваших интересах. Поэтому вам нужно организовать все условия для того, чтобы форма оформления заказа записывалась правильно, и Яндекс Спеллер – один из методов.

Так же и с формой контактов, комментариев и другими. Иногда бывают такие опечатки, которые совершенно меняют смысл предложения, и Яндекс Спеллер поможет посетителям писать правильно.

Какие ошибки исправляет Спеллер

Яндекс Спеллер – это машина. Как и любая машина – она не совершенна и далека от человеческого мозга. Функции, которые она может выполнять, следующие:

  • Выполняет проверку букв, которые вписаны в слово не правильно или отсутствуют. Например, Яндекс Спеллер подчеркнёт кальцо, компютер, теллефон.
  • Также будут выделены слова, в которых использован неверный регистр букв. Например, Яндекс Спеллер обратит внимание на САйт, вЕЧЕР.
  • Кроме того, Яндекс Спеллер наблюдает за повторением слов, которые идут подряд. Например, утром мы пили пили кофе.

Ошибки, связанные с пунктуацией, то есть расстановкой знаков препинания, Яндекс Спеллер не проверяет. Это его недостаток. Однако те опечатки, которые он может обнаружить, являются самыми часто совершаемыми посетителями.

Яндекс Спеллер находит ошибки текста, сравнивая слова со своей базой правильных слов. Поэтому количество поддерживаемых языков ограниченно: для русского 306 миллионов слов, для украинского 1,8 миллионов слов и для английского 150 000 слов. Остальные языки не поддерживаются.

Плагины для WordPress для подключения Яндекс Спеллера

Яндекс предлагает целых два разных плагина, которые помогают реализовать функции спеллера на своём сайте — Q2W3 Yandex Speller, Yandex Speller Application. Скачать их можно в панели администратора WordPress или на странице этого сервиса. Наличие двух плагинов для Яндекс Спеллера уменьшает вероятность неработоспособности – не получится с одним, можно попробовать с другим.

Yandex Speller Application

Проверка правописания в TinyMCE, используя Яндекс.Спеллер.

Проверка правописания в TinyMCE, используя Яндекс.Спеллер.

Описание

Модифицирует в визуальном редакторе TinyMCE стандартную проверку правописания на проверку правописания используя сервис Яндекс.Спеллер, что очень подходит для проверки текстов на русском языке.

Скачать

Скачать Версию 1.0.2. с сайта wordpress.org

Установка

Распакуйте архив yandex-speller-application.zip в /wp-content/plugins/ директорию. Активируйте плагин в «Plugins» меню в WordPress.

Q2W3 Yandex Speller

Плагин использует в TinyMCE сервис проверки правописания Яндекс.Спеллер

Проверка правописания в TinyMCE, используя Яндекс.Спеллер.

Описание

Модифицирует в визуальном редакторе TinyMCE стандартную проверку правописания на проверку правописания используя сервис Яндекс.Спеллер, что очень подходит для проверки текстов на русском языке.

Скачать

Скачать Версию 1.0.2. с сайта wordpress.org

Установка

Распакуйте архив yandex-speller-application.zip в /wp-content/plugins/ директорию. Активируйте плагин в «Plugins» меню в WordPress.

Плагины для Jomla для подключения Яндекс Спеллера

Яндекс предлагает целых два разных плагина, которые помогают реализовать функции спеллера на своём сайте — Q2W3 Yandex Speller, Yandex Speller Application. Скачать их можно в панели администратора WordPress или на странице этого сервиса. Наличие двух плагинов для Яндекс Спеллера уменьшает вероятность неработоспособности – не получится с одним, можно попробовать с другим.

Yandex Speller Application

Проверка правописания в TinyMCE, используя Яндекс.Спеллер.

Проверка правописания в TinyMCE, используя Яндекс.Спеллер.

Описание

Модифицирует в визуальном редакторе TinyMCE стандартную проверку правописания на проверку правописания используя сервис Яндекс.Спеллер, что очень подходит для проверки текстов на русском языке.

Скачать

Скачать Версию 1.0.2. с сайта wordpress.org

Установка

Распакуйте архив yandex-speller-application.zip в /wp-content/plugins/ директорию. Активируйте плагин в «Plugins» меню в WordPress.

Q2W3 Yandex Speller

Плагин использует в TinyMCE сервис проверки правописания Яндекс.Спеллер

Проверка правописания в TinyMCE, используя Яндекс.Спеллер.

Описание

Модифицирует в визуальном редакторе TinyMCE стандартную проверку правописания на проверку правописания используя сервис Яндекс.Спеллер, что очень подходит для проверки текстов на русском языке.

Скачать

Скачать Версию 1.0.2. с сайта wordpress.org

Установка

Распакуйте архив yandex-speller-application.zip в /wp-content/plugins/ директорию. Активируйте плагин в «Plugins» меню в WordPress.

Плагины для Drupal для подключения Яндекс Спеллера

Яндекс предлагает целых два разных плагина, которые помогают реализовать функции спеллера на своём сайте — Q2W3 Yandex Speller, Yandex Speller Application. Скачать их можно в панели администратора WordPress или на странице этого сервиса. Наличие двух плагинов для Яндекс Спеллера уменьшает вероятность неработоспособности – не получится с одним, можно попробовать с другим.

.

.

.

.

.

www.web-patrol.net

Какие ошибки исправляет проверка орфографии?

  • Орфографические ошибки — несовпадение с мультиязычным словарем.
  • Опечатки, пропущенные или лишние буквы.
  • Пропущенные пробелы между словами.
  • Грамматические и морфологические ошибки

Разместите текст в поле «Текст» и нажмите кнопку «Проверить» — система покажет найденные предположительные ошибки и выделит их в тексте подчеркиванием и цветом.

На каком языке проверяется правописание и ошибки?

По умолчанию грамотность текста анализируется на русском языке.

Для проверки орфографии на другом языке выберите его из выпадающего меню: английский, немецкий, испанский, французский, китайский, украинский, японский, португальский, польский, итальянский, турецкий, арабский, вьетнамский, корейский, урду, персидский, хинди, голландский, финский.

Пример отчета проверки орфографии и грамматики онлайн

Отчет проверки орфографии и грамматики онлайн

Какой объем текста можно проверить на орфографию?

Максимальный объем текста для одной проверки — 100 000 символов с пробелами. Чтобы проверить статью или документ большего размера, разбейте его на фрагменты и проверьте их по очереди.

Вы можете проверить неограниченное количество текстов бесплатно и без регистрации.

Проверка пунктуации онлайн — исправление ошибок в тексте от Адвего

Сервис Адвего поможет не только найти плагиат онлайн бесплатно и определить уникальность текста, но и сможет провести проверку пунктуации с указанием опечаток в знаках препинания и указать наличие орфографических ошибок онлайн.

Адвего рекомендует проверить орфографию и пунктуацию онлайн на русском, украинском, английском и еще более чем 20 языках в своем качественном мультиязычном сервисе орфо онлайн!

advego.com

  #Область Yandex_speller   // ~~~~~ ~~~~~ ~~~~~ ~~~~~ ~~~~~ ~~~~~ ~~~~~ ~~~~~ ~~~~~ ~~~~~  //						Yandex speller   // ~~~~~ ~~~~~ ~~~~~ ~~~~~ ~~~~~ ~~~~~ ~~~~~ ~~~~~ ~~~~~ ~~~~~  // Проверка орфографии средствами Yandex speller через HTTP GET  // https://tech.yandex.ru/speller/doc/dg/concepts/speller-overview-docpage/  //  // Функция возвращает структуру со следующими парами Ключ-Значение:  //	БезОшибок, КоличествоОшибок, ИсходныйТекст, ИсправленныйТекст, ШаблонТекста, Ошибки  //	БезОшибок (булево)			- Текст не содержит/содержит ошибки.  //	КоличествоОшибок (число)	- Количество ошибок в тексте  //	ИсходныйТекст (строка)		- Текст переданый в функцию  //	ИсправленныйТекст (строка)	- Текст с исправленными ошибками (ошибки заменены на первую подсказку)  //	ШаблонТекста				- Текст в котором места ошибок обрамлены в "ИндексОшибки"   //	Ошибки (массив структур)	- Состоит из КодОшибки (число),   //									ОписаниеОшибки (строка), ПозицияСлова (число), НомерСтроки (число),   //									НомерСтолбца (число), ДлинаСлова (число), Подсказки (массив строк)   // В случае неудачи функция возвращает "Неопределено" и выводит сообщение об ошибке.  //  // Параметры:  //	Текст						- [обязательный](строка)  //								параметром передается текст на проверку  //	Язык						- [необязательный](строка)  //								Языки проверки (перечисляются через запятую).  //								Возможные значения:  //									ru – русский;  //									uk – украинский;  //									en – английский.  //								По умолчанию: "ru,en".  //	Опции						- [необязательный](число)  //								Опции Яндекс.Спеллера.  //								Значением параметра является сумма значений требуемых опций,  //								см. https://tech.yandex.ru/speller/doc/dg/reference/speller-options-docpage/  //								Например, Опции = 5 - это сумма опций IGNORE_UPPERCASE и IGNORE_URLS.  //								По умолчанию Опции = 31 (IGNORE_UPPERCASE, IGNORE_DIGITS, IGNORE_URLS, FIND_REPEAT_WORDS, IGNORE_LATIN).								  //	Формат						- [необязательный](строка)  //								Формат проверяемого текста.  //								Возможные значения:  //									plain - текст без разметки (значение по умолчанию)  //								 html - HTML-текст.  //	ИсправлятьИсходныйТекст		- [необязательный](булево)   //								если Истина, то исходный текст исправляется  //								может быть полезно, если использовать как процедуру и возвращать первый параметр "Текст".  //								По умолчанию Ложь.  //	СообщатьОбОшибках			- [необязательный](булево)   //								если Истина (значение по умолчанию), то будут выводиться сообщения об ошибках  //	Словарь						- [необязательный](строка)   //								если заданы метаданные словаря (вида: "Справочник.Словарь"),   //								то будут исключаться из ошибочных слова содержащиеся в наименованиях справочника "Словарь".  //								Если передана строка с разделителями ";",   //								то вместо справочника словаря будет использоваться она.  //								По умолчанию пустая строка.  //	МинДлинаСлова				- [необязательный](число)   //								минимальная длина слова подлежащего проверке  //								По умолчанию 0 (проверять все слова).  Функция YandexSpeller(	Текст,   						Знач Язык						= "ru,en",   						Знач Опции						= 31,   						Знач Формат						= "plain",   						Знач ИсправлятьИсходныйТекст	= Ложь,   						Знач СообщатьОбОшибках			= Истина,  						Знач Словарь					= "",  						Знач МинДлинаСлова				= 0) Экспорт  	// Откидываю все лишнее  	// и не мучаю веб сервис по напрасну.  	Если ТипЗнч(Текст) <> Тип("Строка") Или СтрДлина(Текст)>10000 Тогда  		Сообщение		= Новый СообщениеПользователю;  		Сообщение.Текст	= "Проверьте передаваемый на проверку текст. Он "  		+ ?(ТипЗнч(Текст)<>Тип("Строка"), "не является строкой.", "слишком длинный.");  		Сообщение.Сообщить();  		Возврат Неопределено;  	ИначеЕсли ТипЗнч(Текст) = Тип("Строка") И ПустаяСтрока(Текст) Тогда  		Возврат Новый Структура("БезОшибок,КоличествоОшибок,Ошибки,ИсходныйТекст,ИсправленныйТекст,ШаблонТекста",  		Истина, 0, Новый Массив, Текст, Текст, Текст);  	КонецЕсли;  	  	Попытка  		// Задаю соответсвие для расшифровки кодов ошибок  		КодыОшибок	= Новый Соответствие;  		КодыОшибок.Вставить(1, "Слова нет в словаре");  		КодыОшибок.Вставить(2, "Повтор слова");  		КодыОшибок.Вставить(3, "Неверное употребление прописных и строчных букв");  		КодыОшибок.Вставить(4, "Текст содержит слишком много ошибок");    		// Подключение к Web сервису через SOAP-интерфейс   		// !!! НЕ ИСПОЛЬЗУЮ, ТК НЕЛЬЗЯ ИСПОЛЬЗОВАТЬ ВСЕ ПАРАМЕТРЫ ЗАПРОСА ИЗ ЗА ОГРАНИЧЕНИЯ ПЛАТФОРМЫ!!!  		//Определения	= Новый WSОпределения("http://speller.yandex.net/services/spellservice?WSDL",,,Неопределено,300);	  		//Прокси		= Новый WSПрокси(Определения, "http://speller.yandex.net/services/spellservice",   		//									"SpellService", "SpellServiceSoap", Неопределено, 300);  		//Данные		= Прокси.checkText(Текст);  		  		// Долблю 10 раз HTTP Get запрос в надежде получить ответ  		Для Счетчик = 1 По 10 Цикл  			ТекстНаПроверку	= СтрЗаменить(Текст, Символы.Таб,	"%20");  			ТекстНаПроверку	= СтрЗаменить(ТекстНаПроверку, " ", "%20");  			  			URL			= СтрШаблон("services/spellservice/checkText?text=%1&lang=%2&options=%3&format=%4", ТекстНаПроверку, СокрЛП(Язык), СокрЛП(Опции), СокрЛП(Формат));  			//Заголовки	= Новый Соответствие();  			//Заголовки.Вставить("Accept", "text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,image/apng,*/*;q=0.8");  			//Заголовки.Вставить("Accept-Encoding", "gzip, deflate");  			//Заголовки.Вставить("Accept-Language", "en-US,en;q=0.8,ru;q=0.6");  			//Заголовки.Вставить("Cache-Control", "max-age=0");  			//Заголовки.Вставить("Connection", "keep-alive");  			//Заголовки.Вставить("Host", "speller.yandex.net");  			//Заголовки.Вставить("Upgrade-Insecure-Requests", "1");			  			//Заголовки.Вставить("User-Agent", "Mozilla/5.0 (Windows NT 6.3; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/61.0.3163.100 Safari/537.36");  			//Заголовки.Вставить("X-Compress", "null");			  			  			HTTPСоединение	= Новый HTTPСоединение("speller.yandex.net", 80, , , , Счетчик*10);  			//HTTPСоединение= Новый HTTPСоединение("speller.yandex.net", 443,,,, Счетчик*10, Новый ЗащищенноеСоединениеOpenSSL());  			HTTPЗапрос		= Новый HTTPЗапрос(URL); //, Заголовки);		  			HTTPОтвет		= HTTPСоединение.Получить(HTTPЗапрос);  			Если HTTPОтвет.КодСостояния	= 200 Тогда Прервать КонецЕсли;			  		КонецЦикла; // Для Счетчик = 1 По 10   		Если HTTPОтвет.КодСостояния <> 200 Тогда  			Сообщение		= Новый СообщениеПользователю;  			Сообщение.Текст	= "Не удалось соединиться с сервисом yandex.speller.  							|Проверьте подключение к интернету.";  			Сообщение.Сообщить();  			Возврат Неопределено;			  		КонецЕсли; // Если HTTPОтвет.КодСостояния <> 200  		  		// Перебираю XML ответ  		ЧтениеXML		= Новый ЧтениеXML();   		ЧтениеXML.УстановитьСтроку(HttpОтвет.ПолучитьТелоКакСтроку());   		ПостроительDOM	= Новый ПостроительDOM;  		Попытка   	 	ДокументDOM		= ПостроительDOM.Прочитать(ЧтениеXML);  		Исключение  			Сообщение		= Новый СообщениеПользователю;  			Сообщение.Текст	= "Не возможно прочитать ответ сервиса Yandex Speller.  							|Возможно битая кодировка." + Символы.ПС + ОписаниеОшибки();  			Сообщение.Сообщить();  			Возврат Неопределено;						  		КонецПопытки;  		Ошибки			= Новый Массив;  		ОшибкиСтрокой	= "";   		ЭлементыError	= ДокументDOM.ПолучитьЭлементыПоИмени("Error");  		сАтрибутов		= Новый Соответствие;  		Для Каждого Атрибут Из СтрРазделить("cod:КодОшибки;pos:ПозицияСлова;row:НомерСтроки;col:НомерСтолбца;len:ДлинаСлова", ";", Ложь) Цикл  			сАтрибутов.Вставить(Лев(Атрибут, 3), Сред(Атрибут, 5));	  		КонецЦикла; // Для Каждого Атрибут Из СтрРазделить()  		ДЛЯ КАЖДОГО ЭлементError ИЗ ЭлементыError ЦИКЛ  			Попытка  				Ошибка		= Новый Структура("Подсказки", Новый Массив);  				Для Каждого Атрибут Из ЭлементError.Атрибуты Цикл  				Ошибка.Вставить(сАтрибутов.Получить(Лев(Атрибут.Имя, 3)), Число(Атрибут.Значение));  				КонецЦикла; // Для Каждого Атрибут Из ЭлементError.Атрибуты  				Ошибка.Вставить("ОписаниеОшибки",	КодыОшибок.Получить(Ошибка.КодОшибки));   				Слова		= ЭлементError.ПолучитьЭлементыПоИмени("word");  				Если Не Слова.Количество() Тогда Продолжить КонецЕсли;  				Ошибка.Вставить("Слово", Слова[0].ТекстовоеСодержимое);  				ОшибкиСтрокой	= СтрШаблон("%1,""%2""", ОшибкиСтрокой, СтрЗаменить(Ошибка.Слово, """", ""));  				Подсказки	= ЭлементError.ПолучитьЭлементыПоИмени("s");  				Для Каждого Подсказка Из Подсказки Цикл  				Ошибка.Подсказки.Добавить(Подсказка.ТекстовоеСодержимое);  				КонецЦикла; // Для Каждого Подсказка Из Подсказки   				Ошибки.Добавить(Ошибка);  			Исключение  				Сообщение		= Новый СообщениеПользователю;  				Сообщение.Текст	= "Ошибка при разборе ответа от сервера. Итерация будет пропущена." + Символы.ПС + ОписаниеОшибки();  				Сообщение.Сообщить();  			КонецПопытки;  		КОНЕЦЦИКЛА; // ДЛЯ КАЖДОГО ЭлементError ИЗ ЭлементыError  		ОшибкиСтрокой	= Сред(ОшибкиСтрокой, 2);  		  		// Немного прибираюсь за собой  		Заголовки = Неопределено; HTTPСоединение = Неопределено;   		HTTPЗапрос = Неопределено; HTTPОтвет = Неопределено;  		ЧтениеXML.Закрыть(); ЧтениеXML = Неопределено; ДокументDOM = Неопределено;   		ПостроительDOM = Неопределено; сАтрибутов = Неопределено;  				  		// Если надо найти слова-исключения из справочника  		ЕСЛИ ТипЗнч(Словарь) = Тип("Строка") И СтрДлина(ОшибкиСтрокой) И СтрДлина(Словарь) И СтрНачинаетсяС(Словарь, "Справочник.") ТОГДА 		  			#Если НаСервере Тогда				  			Если Метаданные.Справочники.Найти(Сред(Словарь, 12)) <> Неопределено Тогда				  				Запрос	= Новый Запрос("  				|ВЫБРАТЬ Наименование  				|ИЗ "+Словарь+"  				|ГДЕ Наименование В("+ОшибкиСтрокой+")");  				Словарь	= Запрос.Выполнить().Выгрузить().ВыгрузитьКолонку("Наименование");  			КонецЕсли;  			#КонецЕсли  		ИНАЧЕЕСЛИ ТипЗнч(Словарь) = Тип("Строка") ТОГДА // Если словарь передан строкой   			Словарь = СтрРазделить(Словарь, ";", Ложь);  		КОНЕЦЕСЛИ; // ЕСЛИ ТипЗнч(Словарь) = Тип("Булево") И Словарь  		  		// Удаляю из ошибок короткие и словарные слова  		КолвоЭлтовКоллекции	= Ошибки.Количество();   		ДЛЯ оИндекс = 1 ПО КолвоЭлтовКоллекции ЦИКЛ  			Индекс		= КолвоЭлтовКоллекции - оИндекс;  			Ошибка		= Ошибки[Индекс];  			// Если слово слишком короткое, чтоб быть ошибкой  			Если МинДлинаСлова И Ошибка.ДлинаСлова < МинДлинаСлова Тогда   				Ошибки.Удалить(Индекс);					  			ИначеЕсли ТипЗнч(Словарь) = Тип("Массив") Тогда  				// Если слово является словарным (исключением)  	  				Для Каждого Слово Из Словарь Цикл  					Если СокрЛП(Нрег(Ошибка.Слово)) = СокрЛП(Нрег(Слово)) Тогда  						Ошибки.Удалить(Индекс); Прервать;   					КонецЕсли; // Если СокрЛП(Нрег(Ошибка.word)) = СокрЛП(Нрег(Слово))  				КонецЦикла; // Для Каждого Слово Из Словарь 		  			КонецЕсли; // Если Не МинДлинаСлова И Ошибка.len < МинДлинаСлова  		КОНЕЦЦИКЛА; // ДЛЯ оИндекс = 1 ПО КолвоЭлтовКоллекции  		  		// Перебираю все ошибки  		ИсходныйТекст		= Текст;  		ИсправленныйТекст	= Текст;  		ДЛЯ КАЖДОГО Ошибка ИЗ Ошибки ЦИКЛ  			Подсказки	= "";  			// Перебираю все доступные подсказки   			// для уведомления пользователя о доступных вариантах  			Для Каждого Подсказка Из Ошибка.Подсказки Цикл  				Подсказки	= Подсказки + Подсказка + ", ";  			КонецЦикла;  			Подсказки	= Лев(Подсказки, СтрДлина(Подсказки)-2);  			Если Ошибка.Подсказки.Количество() Тогда  				ИсправленныйТекст	= СтрЗаменить(ИсправленныйТекст, Ошибка.Слово, Ошибка.Подсказки[0]); 	  			КонецЕсли; // Если Ошибка.Подсказки.Количество()			  			Если СообщатьОбОшибках Тогда  				// Непосредственно вывод по ошибке  				Сообщение		= Новый СообщениеПользователю;  				Сообщение.Текст	= СтрШаблон("Ошибка в слове: ""%1"". %2. %3",   									Ошибка.Слово,   									Ошибка.ОписаниеОшибки,  									?(Ошибка.Подсказки.Количество(),   										Символы.ПС + "Возможно Вы хотели написать: " + Подсказки, ""));  				Сообщение.Сообщить();  			КонецЕсли; // Если СообщатьОбОшибках  		КОНЕЦЦИКЛА; // ДЛЯ КАЖДОГО Ошибка ИЗ Данные.error  		  		Если ИсправлятьИсходныйТекст Тогда Текст = ИсправленныйТекст КонецЕсли;  		  		// Создаю шаблон строки с ошибками  		// где индекс массива ошибок соответсвует тегу Индекс  		ШаблонТекста	= ИсходныйТекст;  		КолвоЭлтовКоллекции	= Ошибки.Количество();   		Для оИндекс = 1 По КолвоЭлтовКоллекции Цикл  			Индекс			= КолвоЭлтовКоллекции - оИндекс;  			Ошибка			= Ошибки[Индекс];  			ШаблонТекста	= СтрШаблон("%1%2%3",  							Лев(ШаблонТекста, Ошибка.ПозицияСлова), Индекс, Сред(ШаблонТекста, Ошибка.ПозицияСлова+Ошибка.ДлинаСлова+1));			  		КонецЦикла; // Для оИндекс = 1 По КолвоЭлтовКоллекции  		  		Возврат Новый Структура("БезОшибок,КоличествоОшибок,Ошибки,ИсходныйТекст,ИсправленныйТекст,ШаблонТекста",  								Не Булево(Ошибки.Количество()), Ошибки.Количество(), Ошибки, ИсходныйТекст, ИсправленныйТекст, ШаблонТекста);			  	Исключение  		Сообщение		= Новый СообщениеПользователю;  		Сообщение.Текст	= "Не удалось проверить орфографию." + Символы.ПС + ОписаниеОшибки();  		Сообщение.Сообщить();  		Возврат Неопределено;  	КонецПопытки;  КонецФункции // YandexSpeller()  // ~~~~~ ~~~~~ ~~~~~ ~~~~~ ~~~~~ ~~~~~ ~~~~~ ~~~~~ ~~~~~ ~~~~~  #КонецОбласти

infostart.ru

Что входит в Яндекс Спеллер?

Поддержка формата НТМL. API сервиса позволит найти ошибки не только в обычном тексте, но и в содержимом страниц HTML.

Поддержка ASPELL/ISPELL. Пользователь может применять Спеллер в самых различных редакторах текста, которые работают с ASPELL.

Словарь, который постоянно обновляется. Например, в последнюю версию были добавлены слова с приставкой «пол».

Как происходит проверка?

В основе программы лежит аналитика частоты употребления тех или иных слов, а это помогает осуществлять проверку наиболее точно, а также оказывает помощь при выборе вариантов подсказки. Кроме того в сервисе предусмотрено большое количество разнообразных опций, что позволяет максимально упростить работу и подстроить сервис под себя.

Спеллер постоянно обновляется и дополняется новыми словами (а потому не удивляется словам «плагин», «роутер» или «кэшироваться»). Проверяя сложный текст с терминами, сервис не будет без надобности подчеркивать его красным.

Как использовать Yandex Speller?

Например, клиент вашего сайта собирается что-то заказывать у вас, заполнить анкету, создать файл с резюме или же написать сообщение. В этих случаях сервис от Яндекса поможет найти ошибки и исправить их автоматически.

Кроме этого, Яндекс Спеллер помогает тем, кто ежедневно загружает огромные объемы текста и физически не может их проверить. В этом случае текст просто вставляется в окно проверки, выбирается команда «Проверить» —  и все неверно написанные слова будут выделены, а ваше время — не затрачено на долгую и утомительную проверку!

Сервис проверки правописания анализирует текст и слова исходя из современных орфографических и лексических правил. Безусловно, не гарантируется стопроцентной вероятности нахождения и исправления всех ошибок, но все же большинство неверных слов будет найдено благодаря проверке из орфографического словаря.

Какие ошибки сервис сможет найти и исправить?

1. Если в слове пропущена или, наоборот, есть лишняя буква, ошибка («пррезентация», «прзнтация», «призентация»).

2. Если использован КапсЛок не по назначению («пРЕЗЕНТАЦИЯ»)- так называемая «ошибка капитализации», то есть неправильное написание прописных и строчных букв в слове.

3. Если одно и то же слово ошибочно использовано дважды («Презентация прошла прошла успешно»).

Ошибки пунктуации, грамматики (например, ошибки в согласовании слов) и стилистики Спеллер не находит и не исправляет. Однако они не так бросаются в глаза, как грубейшие ошибки орфографии, а потому пользователи и посетители вашего сайта могут их и не заметить.

Яндекс Спеллер стремится облегчить жизнь пользователя, пользующегося большими объемами контента, не имеющего времени на вдумчивую проверку, и не дает ему забыть правила русского языка.

softgallery.ru

Онлайн проверка орфографии

Яндекс Спеллер

Яндекс Спеллер позволяет проверить правописание на 3-х языках: русском, английском и украинском. Работа Спеллера основывается на использовании орфографического словаря. Более того, этот словарь включает в себя множество современных слов и постоянно пополняется.

Но, кроме стандартных возможностей, у Спеллера есть 2 особые:

  • Подключить проверку орфографии на свой сайт, настроить стили оформления. Разве плохо иметь свою собственную онлайн проверку правописания? Это задержит посетителей на сайте, что не может не радовать. И тем более, это может сформировать постоянную аудиторию, которая будет пользоваться онлайн проверкой орфографии на Вашем сайте. Работу можно посмотреть ниже.

Проверка правописания онлайн

 


Инструкция по подключению Яндекс Спеллера на своем сайте.

  • Очень часто, при написании статьи, бывают затруднения с написание какого–нибудь слова. Поэтому, изначально я писал в Word, а уже потом добавлял на сайт. Но у этого метода было 2 очень неудобных для меня момента: Яндекс спеллер имеет куда больший словарь, с кучей современных слов, в отличие от Ворда. И в цепи Ворд – редактор – сайт присутствовало лишнее звено, которое можно было достаточно легко отцепить с помощью подключения api Yandex Спеллера непосредственно к редактору WordPress.

Подключить можно с помощью плагинов. Устанавливать любой на выбор:

  1. Q2W3 Yandex Speller
  2. Yandex Speller Application

Установить их можно и из панели администратора WordPress.

Но MS Word не стоит откидывать, так как это одна из лучших программ проверки пунктуации, сайты онлайн проверки пунктуации определенно ей уступают.

Проверка орфографии на сайте от Яндекса

Проверка орфографии сайта. Если текст уже опубликован на сайте, то правописание текста можно проверить с помощью онлайн сервиса проверки правописания от Яндекса:

http://webmaster.yandex.ua/spellcheck.xml.

Достаточно просто ввести Url и все слова с ошибками будут выделены желтым цветом.

Как и Спеллер, сервис проверки орфографии основывается на работе орфографического словаря с большим количеством современных слов.

needsite.net


You May Also Like

About the Author: admind

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *

Этот сайт использует Akismet для борьбы со спамом. Узнайте как обрабатываются ваши данные комментариев.